Forums

Username:  

Password:  

       
Login Help

  LATEST POSTS  
 
America's Army Launc..
Learning BASICS of A..
can u give us hints ..
AA3 New Patch Releas..
Better Realism Alter..

Keywords:
 

More search options

  HOT TOPICS  
 
AA3 Known Issues
AA Challenge Winner
Common Solutions
Training Missions
» See more topics
 

    Page 1 of 1     

 Yes, AA 2.5 for linux still works 
 

adamcaa

Recruit
Posts: 3
Joined: 01 Jul 2010

      Posted: 01 Jul 2010 07:01 Profile


I've installed it in Ubuntu 8.04, and 8.10 this past week, click this link for instructions:
https://help.ubuntu.com/commun...casArmy

link to download America's Army 2.5.0 for linux:
http://www.filefront.com/thank...5fca05c

punkbuster setup download page:
http://www.evenbalance.com/ind...tup.php

installation:

0. sudo apt-get install libstdc++5
1. change into directory where files are located
2. sudo sh ./armyops250linux.run
3. unzip pbsetup.zip
4. sudo ./pbsetup.run
5. add america's army, check for updates
6. run game: /usr/local/games/armyops//armyops



Last edited by adamcaa on 13 Aug 2010 22:25; edited 1 time in total
NimaSepassi

Recruit
Posts: 4
Joined: 11 Aug 2010

      Posted: 11 Aug 2010 18:35 Profile


Hi,

I tried this to no avail. Getting following message when typing armyops:

./armyops-bin: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

I didn't do the punk buster stuff (ie steps 3, 4 and 5)

Please advise.

NimaSepassi

Recruit
Posts: 4
Joined: 11 Aug 2010

      Posted: 11 Aug 2010 18:42 Profile


BTW, I'm running Linux Mint 9 Isadora LXDE 32 bit if that makes a difference.

adamcaa

Recruit
Posts: 3
Joined: 01 Jul 2010

      Posted: 13 Aug 2010 22:22 Profile


Problem: ./armyops-bin: error while loading shared libraries: libstdc++.so.5: cannot open shared object file:
No such file or directory

Fix: sudo apt-get install libstdc++5

NimaSepassi

Recruit
Posts: 4
Joined: 11 Aug 2010

      Posted: 13 Aug 2010 22:46 Profile


When I run
Code:

sudo apt-get install libstdc++5


I get

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package libstdc++5

Voyd

Recruit
Posts: 3
Joined: 02 May 2006

      Posted: 21 Aug 2010 05:49 Profile


NimaSepassi wrote:

When I run
Code:

sudo apt-get install libstdc++5


I get

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package libstdc++5



The following works on 64-bit Ubuntu 10.04:

Code:


$ wget http://mirrors.kernel.org/ubuntu/pool/universe/g/gcc-3.3/libstdc++5_3.3.6-20_amd64.deb
$ dpkg-deb -x libstdc++5_3.3.6-20_amd64.deb ia64-libs
$ sudo cp ia64-libs/usr/lib/libstdc++.so.5.0.7 /usr/lib64/

$ wget http://security.ubuntu.com/ubuntu/pool/universe/i/ia32-libs/ia32-libs_20090808ubuntu2_amd64.deb
$ dpkg-deb -x ia32-libs_20090808ubuntu2_amd64.deb ia32-libs
$ sudo cp ia32-libs/usr/lib32/libstdc++.so.5.0.7 /usr/lib32/

$ cd /usr/lib64/
$ sudo ln -s libstdc++.so.5.0.7 libstdc++.so.5

$ cd /usr/lib32
$ sudo ln -s libstdc++.so.5.0.7 libstdc++.so.5



Last edited by Voyd on 21 Aug 2010 22:57; edited 1 time in total
NimaSepassi

Recruit
Posts: 4
Joined: 11 Aug 2010

      Posted: 21 Aug 2010 18:56 Profile


Yes, but I'm running 32 bit not 64 (and now I have installed Ubuntu Studio 10.04 and still having same problem)

Voyd

Recruit
Posts: 3
Joined: 02 May 2006

      Posted: 21 Aug 2010 22:56 Profile


NimaSepassi wrote:

Yes, but I'm running 32 bit not 64 (and now I have installed Ubuntu Studio 10.04 and still having same problem)



For 32-bit you just need to adapt the above instructions. It will be something along the lines of...

Code:


$ wget http://mirrors.kernel.org/ubuntu/pool/universe/g/gcc-3.3/libstdc++5_3.3.6-20_i386.deb
$ dpkg-deb -x libstdc++5_3.3.6-20_i386.deb libstdc++-files
$ sudo cp libstdc++-files/usr/lib/libstdc++.so.5.0.7 /usr/lib/
$ cd /usr/lib/
$ sudo ln -s libstdc++.so.5.0.7 libstdc++.so.5

{FreeStylers}Reaper

Recruit
Posts: 2
Joined: 29 Jan 2011

      Posted: 30 Jan 2011 21:10 Profile


i'm running Linux mint 10
I've installed AASF 2.5.0
but there is no sound ....
the only input setting is Open AL
what's the solution?
please Need help and Need it now....
Crying or Very Sad

Luis_ESO

Recruit
Posts: 1
Joined: 30 Jan 2011

      Posted: 30 Jan 2011 23:28 Profile


Try this man:

sudo apt-get install libstdc5

probably it works

OrkanSpec

Private First Class
Posts: 77
Joined: 19 Aug 2004

      Posted: 12 Feb 2011 18:51 Profile


Hi,
The problem is the the old sound server used by America's Army. To have sound in new Ubuntu/Kubuntu releases, I have to start the following command:
padsp /usr/local/games/armyops/armyops

_____________________
**************************
OrkanSpec
**************************


 Yes, AA 2.5 for linux still works 
 

    Page 1 of 1     

 

Jump to: