Forums

Username:  

Password:  

       
Login Help

  LATEST POSTS  
 
America's Army Launc..
Learning BASICS of A..
can u give us hints ..
AA3 New Patch Releas..
Better Realism Alter..

Keywords:
 

More search options

  HOT TOPICS  
 
Community Sites
Deploy/AMW Features
FAQ Support Issues
Open Letter
» See more topics
 

    Page 1 of 1     

 Linux Server crashes at start (segmentation fault) 
 

)s(LegendaryRyan)s(

Recruit
Posts: 9
Joined: 14 Feb 2007

      Posted: 11 Nov 2009 04:43 Profile


I've tried to start AA server installed on the VPS (Debian 5.0).
I've downloaded the server files from here:
http://k2-solutions.eu/index.p...cfd9b7c
and followed those instructions:

Quote:

Download America's Army 2.8.5.0 Windows Server Files: http://k2-solutions.eu/forum/index.php?p…BData&dataID=25
Extract America's Army 2.8.5.0 Windows Server Files to a directory
Download this file (America's Army 2.8.5.0 Linux Server Runtime)
Extract America's Army 2.8.5.0 Linux Server Runtime to a directory
Overwrite America's Army 2.8.5.0 Windows Server Files (System directory) with the America's Army 2.8.5.0 Linux Server Runtime Files



After extracting the Linux Server Runtime I had to manually download some libraries (DMBS.so and libdbauth.so).


Here's the error I got:
Quote:


$ ./server-bin global Bridge.aao -nohomedir ini=server.ini log=aao.log

Encryption key located and validated.
Missing Class Class Editor.TransBuffer
Cheat protection disabled
Browse: Bridge.aao?Name=Recruit?Class=AGP_Characters.AGP_Character?;Character=Recruit?team=255
No localization: Engine.Progress.LoadingMap (int)
Collecting garbage
Purging garbage
Garbage: objects: 57950->57945; refs: 716740
Still no game class, now trying ini:Engine.Engine.DefaultServerGame
Game class is 'AGP_GameTeamObjective'
Bringing Level Bridge.myLevel up for play (25) appSeconds: 26.528775...
GameInfo::InitGame : bEnableStatLogging True
Checking for new Tours.ini file on dms1.americasarmy.com
Created Stats object Bridge.STS2_DBAuthStatsInfo
Error creating log file!
IMPORTANT: Global server forcing authorization requirement.
Task::Start() - Failed to create thread, error: 12
Start thread failed

IMPORTANT: Global server forcing authorization requirement.
Signal: SIGSEGV [segmentation fault]
Aborting.


Crash information will be saved to your logfile.

Developer Backtrace:
Speicherzugriffsfehler



Speicherzugriffsfehler = segmentation fault

I'd be grateful for help Smile

[-PB-]Punisher

Sergeant
Posts: 434
Joined: 12 Nov 2008

      Posted: 11 Nov 2009 11:05 Profile Finland


check previliges for the server folder that theyre correct, was it they needed to be 775 or so for the punkbuster to work properly.. also i have dull memory trace that segmentation fault came from the corrupted server installation, have had some in history with our AA2.XX servers.. also check that servers start command is correct, if you could copypaste yours, we can eliminate that possibility, AA2XX can be started in linux only one way and one way ONLY to make it work properly Smile

_____________________
Banned? Your brother, friend, dog using your account excuse won't work!!

Embedded Image

)s(LegendaryRyan)s(

Recruit
Posts: 9
Joined: 14 Feb 2007

      Posted: 11 Nov 2009 15:52 Profile


I've reinstalled the whole AA server (using this site http://download.polarbears-fin.../linux/)

I start the server with this command:
Quote:

./server-bin GLOBAL Bridge.aao -nohomedir ini=server.ini log=aao.log



and I get this error now...

Quote:


Encryption key located and validated.
Missing Class Class Editor.TransBuffer
Cheat protection disabled
Browse: Bridge.aao?Name=Recruit?Class=AGP_Characters.AGP_Character?;Character=Recruit?team=255
No localization: Engine.Progress.LoadingMap (int)
Collecting garbage
Purging garbage
Garbage: objects: 57950->57945; refs: 716740
Still no game class, now trying ini:Engine.Engine.DefaultServerGame
Game class is 'AGP_GameTeamObjective'
Bringing Level Bridge.myLevel up for play (25) appSeconds: 21.741606...
GameInfo::InitGame : bEnableStatLogging True
Checking for new Tours.ini file on dms1.americasarmy.com
Created Stats object Bridge.STS2_DBAuthStatsInfo
Error creating log file!
IMPORTANT: Global server forcing authorization requirement.
Task::Start() - Failed to create thread, error: 12
Start thread failed

IMPORTANT: Global server forcing authorization requirement.
Assertion failed: Ptr [File:../Core/Inc/FMallocAnsi.h] [Line: 32]
Executing UObject::StaticShutdownAfterError
Assertion failed: Ptr [File:../Core/Inc/FMallocAnsi.h] [Line: 32]

History:

Exiting due to error
Exiting.
FileManager: Reading 0 GByte 26 MByte 731 KByte 794 Bytes from HD took 0.047061 seconds (0.047061 reading, 0.000000 seeking).
FileManager: 0.000000 seconds spent with misc. duties
Name subsystem shut down

[-PB-]Punisher

Sergeant
Posts: 434
Joined: 12 Nov 2008

      Posted: 12 Nov 2009 09:31 Profile Finland


its not bound to any IP, it will get some errors and crash without that..

here: ./server-bin global SFhospital.aao -nohomedir multihome=IP.IP.IP.IP ini=server.ini log=server.log

OH, and Bridge is not suitable for server startup map Razz sorry, my bad didnt remember it until i read some of my old posts Very Happy

)s(LegendaryRyan)s(

Recruit
Posts: 9
Joined: 14 Feb 2007

      Posted: 12 Nov 2009 15:10 Profile


Unfortunately it still crashes...

Quote:

~/aa.2.8.4.0/System$ ./server-bin global SFhospital.aao -nohomedir multihome=84.200.212.243 ini=server.ini log=aao.log

Encryption key located and validated.
Missing Class Class Editor.TransBuffer
Cheat protection disabled
Browse: SFhospital.aao?Name=Recruit?Class=AGP_Characters.AGP_Character?;Character=Recruit?team=255
No localization: Engine.Progress.LoadingMap (int)
Signal: SIGSEGV [segmentation fault]
Aborting.


Crash information will be saved to your logfile.

Developer Backtrace:
[ 1] ./server-bin [0x876fee9]
[ 2] /lib/libpthread.so.0 [0xb7fbb938]
[ 3] /lib/libc.so.6(memcpy+0x37) [0xb7c89bc7]
[ 4] ./server-bin(_ZN25FBitScrambleArchiveReader9SerializeEPvi+0x19e) [0x875c96e]
[ 5] ./server-bin(_ZN11ULinkerLoad9SerializeEPvi+0x49) [0x870ea79]
[ 6] ./server-bin(_ZlsR8FArchiveRf+0x24) [0x874c164]
[ 7] ./server-bin(_ZlsR8FArchiveR6TArrayI5FQuatE+0xd0) [0x847db20]
[ 8] ./server-bin(_ZlsR8FArchiveR6TArrayI11AnalogTrackE+0x12f) [0x848649f]
[ 9] ./server-bin(_ZlsR8FArchiveR6TArrayI11MotionChunkE+0x1ce) [0x8480a2e]
[10] ./server-bin(_ZN14UMeshAnimation9SerializeER8FArchive+0x69) [0x8439fe9]
[11] ./server-bin(_ZN11ULinkerLoad7PreloadEP7UObject+0x175) [0x870dbe5]
[12] ./server-bin(_ZN7UObject7EndLoadEv+0x104) [0x8737c34]
[13] ./server-bin(_ZN7UObject16StaticLoadObjectEP6UClassPS_PKwS4_jP11UPackageMap+0x121) [0x8737571]
[14] ./server-bin(_Z10LoadObjectI6ULevelEPT_P7UObjectPKwS6_jP11UPackageMap+0x3b) [0x82ba90b]
[15] ./server-bin(_ZN11UGameEngine7LoadMapERK4FURLP13UPendingLevelPK4TMapI7FStringS6_ERS6_+0x5d0) [0x829ed00]
[16] ./server-bin(_ZN11UGameEngine6BrowseE4FURLPK4TMapI7FStringS2_ERS2_+0xcd0) [0x8298ba0]
[17] ./server-bin(_ZN11UGameEngine4InitEv+0x5bb) [0x828d56b]
[18] ./server-bin(_ZN17UServerCommandlet4MainEPKw+0x106) [0x8274426]
[19] ./server-bin(main+0x2f43) [0x8161903]
[20] /lib/libc.so.6(__libc_start_main+0xe5) [0xb7c2d455]
[21] ./server-bin [0x815e4b1]
Unreal Call Stack: FBitScrambleArchiveReader::Serialize <- ULinkerLoad::Serialize <- TArray<< <- TArray<< <- TArray<< <- UMeshAnimation::Serialize <- LoadObject <- ULinkerLoad::Preload <- PreLoadObjects <- UObject::EndLoad <- UObject::StaticLoadObject <- LoadLevel <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- UGameEngine::Init <- UServerCommandlet::Main
Exiting.
FileManager: Reading 0 GByte 18 MByte 861 KByte 692 Bytes from HD took 0.231465 seconds (0.231465 reading, 0.000000 seeking).
FileManager: 0.000000 seconds spent with misc. duties
Name subsystem shut down
Allocation checking disabled

[-PB-]Punisher

Sergeant
Posts: 434
Joined: 12 Nov 2008

      Posted: 13 Nov 2009 17:08 Profile Finland


hmm, if previliges are okay and you drive AA with high enough user rights, im sorry but i possibly cannot remember how did i solve that similar issue on our server Sad

check this tho, it can give you some ideas how to solve the problem: http://www.cyberciti.biz/tips/...ix.html

its kinda overall explanation how those happen and there can be possible answer for your problem Smile

)s(LegendaryRyan)s(

Recruit
Posts: 9
Joined: 14 Feb 2007

      Posted: 14 Nov 2009 17:57 Profile


can you tell me
1) if you're still running a linux server?
2) what linux distro do you use?

[-PB-]Punisher

Sergeant
Posts: 434
Joined: 12 Nov 2008

      Posted: 14 Nov 2009 19:29 Profile Finland


yea m8 Smile

we have no longer linux AA2 server as clan, but as server provider i will be running them Smile and when we had linux AA2 server as clan server, we used centos 5.2 Smile and in few days i get again linux dedi box to test things out, so if you need something done as test, just PM, email, whatever to catch me Very Happy

)s(LegendaryRyan)s(

Recruit
Posts: 9
Joined: 14 Feb 2007

      Posted: 29 Nov 2009 16:39 Profile


hi again
still having the same problem Razz
what i've noticed lately is that i've got no problems to install & run the same AA server on my Ubuntu installed on the local machine

that makes me think that the problem lies in the virtual server configuration
any ideas?
i'd like to stress that in January i was able to run AA server on that VPS :/
just when i try it now (i mean Autumn) it still crashes...........

[-PB-]Punisher

Sergeant
Posts: 434
Joined: 12 Nov 2008

      Posted: 01 Dec 2009 10:47 Profile Finland


id go to the idea that virtual server software has been updated somehow and it does compability issues with AA, just an idea?


 Linux Server crashes at start (segmentation fault) 
 

    Page 1 of 1     

 

Jump to: