Forums

Username:  

Password:  

       
Login Help

  LATEST POSTS  
 
America's Army Launc..
Learning BASICS of A..
can u give us hints ..
AA3 New Patch Releas..
Better Realism Alter..

Keywords:
 

More search options

  HOT TOPICS  
 
2nd Video Challenge
AA3 Known Issues
Common Solutions
Training Missions
» See more topics
  

    « Previous Page        Page 5 of 6     
  Page Jump        Next Page »  

 How to Update or Reinstall PunkBuster in v3.0+ 
 

Spl1nt

Sergeant Major
Posts: 4165
Joined: 17 Jun 2009

      Posted: 31 Jul 2009 12:47 Profile United Kingdom


.maD-TheDevil. wrote:

Every time I join a server I get removed by PB. It was working fine since the beginning but stopped working yesterday and I don't know why. I did what -=[RBF]=-SnipeKill said to do but this time it didn't work.. Any help plz ?



Please create a post in this category addressing us with your problem in as much detail as possible. Thank you.

_____________________
Former AA [Support] Volunteer

.=QUACK=.Major.Pain

Private First Class
Posts: 165
Joined: 14 Aug 2006

      Posted: 31 Jul 2009 16:37 Profile


I posted a fix above.

It happened again to me early last night. Get into the server and play anywhere from 2-10 miutes and get pb kicked. I ran RegistryFix7, fixed all the issues, and played all last night and this afternoon without being kicked once.

Uunko

Recruit
Posts: 11
Joined: 18 Jun 2009

      Posted: 01 Aug 2009 06:21 Profile


Ok I'm really [TOS Violation] off!

Up until today I was playing AA3 no problems at all. This arvo I try to join up and get a AA3.exe crash right after the Punkbuster auth has said I'm ok. I don't get to enter the server or play at all.

I've uninstalled AA3 by deploy twice. Reg cleaned, uninstalled PB and installed again. Uninstalled PB, killed the Punk processes and reinstalled, updated Nvidia drivers to the latest 190.x for WinXP. Defragged my HD. Done everything I have found on the Evenbalance site and killed of any "extra" programs like Avast AV etc which where on and worked before.

I can join a NON PB enabled server no problems.

Seriously this is a complete cluster f*ck fellas.

.maD-TheDevil.

Recruit
Posts: 15
Joined: 26 Jun 2007

      Posted: 01 Aug 2009 11:21 Profile


Im [TOS Violation] tierd of this game !

I've been playing since 1.0 and never had that many problems ! It should have not been released in the first place if it ended up being this [TOS Violation].

I've run RegMechanics, Cleaned all the [TOS Violation] keys, Ive deleted Pb Setup and run Pb again... It doesnt work.

Just wanna give up and go back to 2.8 and stop playing this game !

_____________________
Embedded Image

BOBIOBAD

Recruit
Posts: 1
Joined: 01 Aug 2009

      Posted: 01 Aug 2009 14:49 Profile Slovenia


I never have so much problems with playing AA games with punkbuster and i play this game from first version AA
I do it all what you says guys, but PB still hit me out of game all times.
Im wary said bacause i will stop playing my favorite game Crying or Very Sad

=7Cav=PFC.B.Neil

Recruit
Posts: 17
Joined: 31 Jul 2009

      Posted: 03 Aug 2009 17:33 Profile United Kingdom


AHA! I've been on the aa-support irc for hours. Finally found a solution of being kicked by PB!

*STEAM ONLY*

This solution requires no downloading or visiting websites, which is easy!

First of all, go into your Program Files/Valve/Steam/SteamApps/common/america's army 3/Binaries/
Now, delete the "pb" folder and the "pbsetup".

Now open up your Steam Application and go into "My games" tab.
From here, right click on "America's Army 3" and click "Properties".
Go to the "Local Files" tab and click "Verify integrity of game cache..."
Now let it go to work. After it has completed, restart your computer.

Once you have rebooted, check your Binaries folder again to make sure pb is there.
If it isn't there, repeat the above procedure to "Verify integrity of game cache..."
After this time, you will not need to reboot.

You should now be able to play til your hearts content!

Thankyou Splint and col for the help in order of finding this solution.
Please reply with success or fail storys.

Spl1nt

Sergeant Major
Posts: 4165
Joined: 17 Jun 2009

      Posted: 03 Aug 2009 17:46 Profile United Kingdom


=7Cav=PFC.B.Neil wrote:

AHA! I've been on the aa-support irc for hours. Finally found a solution of being kicked by PB!

Thankyou Splint and col for the help in order of finding this solution.
Please reply with success or fail storys.



No worries.
Please do not be hesitant to be in contact with us should you encounter any difficulty further in respect to this issue or should you be in need of assistance on your AA2/3 account/software.

[BEL]RadicalAtHeart

Private First Class
Posts: 150
Joined: 06 Jan 2006

      Posted: 13 Aug 2009 08:38 Profile Belgium


I knew this for a long time! and it didn't help for the current PB issues

I used the bat file provided by AA3 that didnt help either

the only way to get this game work well is reset your whole computer with a fresh PB install. that should do it.

-=[RBF]=-SnipeKill

Private First Class
Posts: 74
Joined: 17 Apr 2006

      Posted: 22 Aug 2009 21:19 Profile


I went back to XP operation system and start having problems with the pb , I remember i had pb issues on AA2 before AA 3 came out and after i submitted a ticket to pb they send me a info, so this is what i did and it worked for me on that time and alos help me Today on AA3 after i get kicked from the server, I hope this helps some of you,

It looks like PnkBstrB is failing to start. Please make sure you allow the service files in security software like virus scanners and/or firewalls (even if you turn them off while playing).
You will need to allow/unblock the services PnkBstrA.exe and PnkBstrB.exe from your "C:\Windows\system32" folder (or "C:\Windows\SysWOW64"on 64bit systems).
In case of doubt, manually add both to your firewall's allow list.
After the installation process you will only find PnkBstrA, so just make sure this process file is not blocked.
Then try playing on a PB enabled server, in case of a kick, check if PnkBstrB was created and unblock it too.

Please make sure that the PnkBstrA service is set to start automatically every time your computer starts.
Go to: Start menu, Settings, Control Panel, Administrative Tools, Services and change PnkBstrA to start Automatically.
Also look for PnkBstrB service and just click on restart or start.

If PnkBstrB is never created, please do the following:

* Make sure you have rebooted/restarted your computer since having this issue.
* Download the latest version of PBSVC from:
http://www.evenbalance.com/dow...svc.exe

* Disable your security software (virus scanners for example) temporarily (disconnect your computer from the internet if you feel this is unsafe).
* Make sure you don't play through a network share.
* Make sure you run the latest drivers, especially drivers for network adapters.
* Run PBSVC and press the "Test Services" button. This will test all components of the PunkBuster Services, including a trigger to start PnkBstrB.
* Check if PnkBstrB.exe is now available in the "C:\Windows\system32" folder.
* Enable your security software again if closed and add PnkBstrB to the allow list (described above).
* Run the following tool: http://www.softpedia.com/get/A...r.shtml (not for Vista)
* Make sure you do not run the game in a compatibility mode.

* Copy-paste the "Test Services" output from PBSVC in a new note if things are not working correctly and explain further what you have tried additionally.
open a support ticket with Punkbuster Support http://www.evenbalance.com/tro...ame=aao and find the armyops.log
file located in the ../America's Army/system folder. Open it with a text program and search for a PunkBuster kick reason, and paste that in your Support ticket. and also the test note if the problem persist.

_____________________
Embedded Image

Outlawstar15a2

Recruit
Posts: 2
Joined: 21 Sep 2009

      Posted: 22 Sep 2009 15:34 Profile


I have Vista, with 3.0.6 Steam client. Been installed on my system two days now and still can't get PB to initialize. I tried uninstalling/reinstalling, I tried the PB update utilitiy from the link on the first page. I can get as far as PB initialization but after that AA3 freezes and I have to manually force the game to terminate via Task Manager. I am this close to uninstalling it from my system.... Any advice? And I cant use the Deploy client because I get the "Program too big to fit in memory" error and I have 2 Gigs so I definitely meet the minimum requirement....

Fuerte

Private First Class
Posts: 211
Joined: 13 Sep 2003

      Posted: 25 Sep 2009 06:44 Profile


Actually, I am using Windows 7 64-bit, and I have problems with punkbuster, but I eventually get it to work each day. I'm not sure what is the trick, I usually run pbsetup.exe and the other exe (pbsvc.exe?) and sometimes after this it starts working.

Roy_Batty

Recruit
Posts: 1
Joined: 26 Sep 2009

      Posted: 26 Sep 2009 14:07 Profile


I had the problem with RESTRICTION: Service Communication Failure: PnkBstrB.exe heartbeats stopped.
On OS Vistax64
Tryed reinstalling uninstalling firwall all of that.
I found in the registry the PnkBstrB service registry keys are missing.
Using PnkBstrA Registry keys as a guide I recreated the PnkBstrB services in the registry and have had no problem since.

Code:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PnkBstrB
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\PnkBstrB
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\PnkBstrB



After creating the keys and their entries reboot so the PnkBstrB service can start..

Warning it is possibil to make your computor never boot again by incorrectly editing the registry- but rare.
Dont delete anything you dont fully understand. And do a full registry backup before any edit. Razz

={crash}=

Recruit
Posts: 7
Joined: 09 Dec 2007

      Posted: 12 Oct 2009 02:55 Profile Australia


I have been playing AA3 from the start with out to many probs, some small PB issue but have found all fixs on the forums.

But the last week PB keeps on kicking me as soon as I join a game.

I found this on this forum and it worked.

****************************************************************************************************
STEAM ONLY*

This solution requires no downloading or visiting websites, which is easy!

First of all, go into your Program Files/Valve/Steam/SteamApps/common/america's army 3/Binaries/
Now, delete the "pb" folder and the "pbsetup".

Now open up your Steam Application and go into "My games" tab.
From here, right click on "America's Army 3" and click "Properties".
Go to the "Local Files" tab and click "Verify integrity of game cache..."
Now let it go to work. After it has completed, restart your computer.

Once you have rebooted, check your Binaries folder again to make sure pb is there.
If it isn't there, repeat the above procedure to "Verify integrity of game cache..."
After this time, you will not need to reboot.

********************************************************************************
this fixed my PB issue only till i log out of AA3. If i try to log on say 3 hours later in same day I get kicked by PB. If i do the above again its all ok. I had 2 day were i did play on and off and had no issue, but again today PB kick do the above fix and its ok again.


What is going on, Can anyone help me.

prka

Recruit
Posts: 8
Joined: 10 Oct 2009

      Posted: 14 Oct 2009 06:21 Profile


I have the same problem that started about 10 days ago. And the problem is that i get kicked by punkbuster.

I have Win XP SP 3, Intel Core2 Duo E8400 @ 3 GHz, Gigabyte X48-DS4, 2 GB RAM @ 800 MHz, ATI Radeon HD 4870 512 Mb

1.I have the newest pbsetup.exe(3.4), i added the game and updated it, the versions are the same as here: http://www.evenbalance.com/

2. i run the pbsvc.exe, uninstall the service, then i install the service, and everything is fine BUT i still get kicked from servers Crying or Very Sad

anyone could help me..?, should i contact evenbalance?

Most Loyal

Private First Class
Posts: 188
Joined: 18 Nov 2003

      Posted: 18 Oct 2009 08:51 Profile Croatia


Does anyone know why am i being kicked from a particular server only, but not immediately, not banned nor anything, but after I get in, pick a team etc...then in like 3-7 minutes i am kicked, f12 doesn't say anything.
All other servers are working fine.
Could it be server misconfiguration or what??
I mean this is really annoying.

_____________________
THE WORLD IS IN A CONSTANT CONSPIRACY AGAINST THE BRAVE!


 How to Update or Reinstall PunkBuster in v3.0+ 
 

    « Previous Page        Page 5 of 6     
  Page Jump        Next Page »  

  

Jump to: