Forums

Username:  

Password:  

       
Login Help

  LATEST POSTS  
 
America's Army Launc..
Learning BASICS of A..
can u give us hints ..
AA3 New Patch Releas..
Better Realism Alter..

Keywords:
 

More search options

  HOT TOPICS  
 
Name that AA map!
FAQ Support Issues
Webmaster Asset Kit
Training Missions
» See more topics
 

    Page 1 of 1     

 Server Crash at Startup 
 

amMaster

Recruit
Posts: 6
Joined: 01 Mar 2007

      Posted: 25 Apr 2009 12:23 Profile Switzerland


Hi@ all

i'm trying to start an aao2.8.4 server on a debian 4.0 VPS, but allway it crashs.

Quote:


Crash information will be saved to your logfile.

Developer Backtrace:
[ 1] ./server-bin [0x876ff19]
[ 2] /lib/tls/i686/cmov/libpthread.so.0 [0xb7fd7bd8]
[ 3] ./server-bin(_ZlsR8FArchiveR13FCompactIndex+0x7e) [0x873e33e]
[ 4] ./server-bin(_ZlsR8FArchiveR6TArrayI5FVertE+0xfa) [0x8316f3a]
[ 5] ./server-bin(_ZN6UModel9SerializeER8FArchive+0x129) [0x830d6e9]
[ 6] ./server-bin(_ZN11ULinkerLoad7PreloadEP7UObject+0x175) [0x870dc15]
[ 7] ./server-bin(_ZN6ULevel9SerializeER8FArchive+0x171) [0x82e2511]
[ 8] ./server-bin(_ZN11ULinkerLoad7PreloadEP7UObject+0x175) [0x870dc15]
[ 9] ./server-bin(_ZN7UObject7EndLoadEv+0x104) [0x8737c64]
[10] ./server-bin(_ZN7UObject16StaticLoadObjectEP6UClassPS_PKwS4_jP11UPackageMap+0x121) [0x87375a1]
[11] ./server-bin(_Z10LoadObjectI6ULevelEPT_P7UObjectPKwS6_jP11UPackageMap+0x3b) [0x82ba90b]
[12] ./server-bin(_ZN11UGameEngine7LoadMapERK4FURLP13UPendingLevelPK4TMapI7FStringS6_ERS6_+0x5d0) [0x829ed00]
[13] ./server-bin(_ZN11UGameEngine6BrowseE4FURLPK4TMapI7FStringS2_ERS2_+0xcd0) [0x8298ba0]
[14] ./server-bin(_ZN11UGameEngine4InitEv+0x5bb) [0x828d56b]
[15] ./server-bin(_ZN17UServerCommandlet4MainEPKw+0x106) [0x8274426]
[16] ./server-bin(main+0x2f43) [0x8161903]
[17] /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xc8) [0xb7c5bea8]
[18] ./server-bin [0x815e4b1]
Unreal Call Stack: FCompactIndex<< <- FVert<< <- TArray<< <- TTransArray<< <- UModel::Serialize <- LoadObject <- ULinkerLoad::Preload <- ULevel::Serialize <- LoadObject <- ULinkerLoad::Preload <- PreLoadObjects <- UObject::EndLoad <- UObject::StaticLoadObject <- LoadLevel <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- UGameEngine::Init <- UServerCommandlet::Main
Exiting.
FileManager: Reading 0 GByte 18 MByte 874 KByte 481 Bytes from HD took 0.152392 seconds (0.152392 reading, 0.000000 seeking).
FileManager: 0.000000 seconds spent with misc. duties
Name subsystem shut down
Allocation checking disabled



I have also downloaded the ServerHotfix but nothing.

thx for help

[-PB-]Punisher

Sergeant
Posts: 434
Joined: 12 Nov 2008

      Posted: 25 Apr 2009 12:49 Profile Finland


whats your startup command and default startup map? check this one out for issues relating to server start: http://forum.americasarmy.com/...=292298

theres my own post which explains the meaning of proper server start command, theres minor bug on the aao manual and im pretty much sure you are starting your server the way the manual shows Smile test those and post the results, if not working, lets think something another solution Smile

_____________________
Banned? Your brother, friend, dog using your account excuse won't work!!

Embedded Image

amMaster

Recruit
Posts: 6
Joined: 01 Mar 2007

      Posted: 25 Apr 2009 12:56 Profile Switzerland


i used

./server-bin global SFhospital.aao -nohomedir multihome=88.80.195.4 ini=server.ini log=server.log

but alway the same error

i tried also without the ini file but nothing to do

Milyardo

Private First Class
Posts: 128
Joined: 18 Aug 2008

      Posted: 25 Apr 2009 17:37 Profile United States


Hi amMaster,
Are you sure you downloaded the full server install? Looks to me like you're just trying to run the hotfix patch without a full server install. You should download the full Linux server, then untar the hotfix into the same directory as full server install.

amMaster

Recruit
Posts: 6
Joined: 01 Mar 2007

      Posted: 25 Apr 2009 18:11 Profile Switzerland


Jeah sure i've done it xD

if u look on line 2 and 17 u can see there is something with a library. what does it mean?
i have looked for this two if they are missing, but they are still there.

i have no idea what the problem could be.

[-PB-]Punisher

Sergeant
Posts: 434
Joined: 12 Nov 2008

      Posted: 26 Apr 2009 03:04 Profile Finland


hmm, what previliges ur running your server? correct me but proper is 664 or 775 needed for the folder aao is unpacked.. try first to drive command as root and if it works then change folder privileges to higher for pb and army to allow do their stuff there.. linux sometimes makes "funny" errors if everything is not as they should Very Happy

amMaster

Recruit
Posts: 6
Joined: 01 Mar 2007

      Posted: 26 Apr 2009 03:34 Profile Switzerland


nothing to do Sad

amMaster

Recruit
Posts: 6
Joined: 01 Mar 2007

      Posted: 26 Apr 2009 16:31 Profile Switzerland


ok i solved the error by reinstalling the VPS System Files, but now i have an other problem.

when i start the server, after it has started succesfully, there are 5 to 6 processes of the same server.

does anyone kown what kind of problem it is?

thx


 Server Crash at Startup 
 

    Page 1 of 1     

 

Jump to: